CVE-2026-21450
CVE-2026-21450 · Bagisto has SSTI in parameter that can lead to RCE
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Bagisto is an open source laravel eCommerce platform. Versions prior to 2.3.10 are vulnerable to server-side template injection via type parameter, which can lead to remote code execution or another exploitation. Version 2.3.10 fixes the issue.
CVSS 7.3 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
bagisto
- Versions
- < 2.3.10: Affected
No fix published
bagisto/bagisto Packagist
- Versions
- v0.1.0
- v0.1.1
- v0.1.2
- v0.1.3
- v0.1.4
- v0.1.4-BETA1
- v0.1.4-BETA2
- v0.1.4-BETA3
- v0.1.4-BETA4
- v0.1.5
- v0.1.6
- v0.1.6-ALPHA1
- v0.1.7
- v0.1.7-BETA1
- v0.1.7-BETA2
- v0.1.8
- v0.1.9
- v0.1.9-BETA1
- v0.2.0
- v0.2.1
- v0.2.2
- v1.0.0
- v1.0.0-BETA1
- v1.1.0
- v1.1.1
- v1.1.2
- v1.2.0
- v1.2.0-BETA1
- v1.3.0
- v1.3.1
- v1.3.2
- v1.3.3
- v1.4.0
- v1.4.1
- v1.4.2
- v1.4.3
- v1.4.4
- v1.4.5
- v1.5.0
- v1.5.1
- v2.0.0
- v2.0.0-BETA-1
- v2.1.0
- v2.1.1
- v2.1.2
- v2.2.0
- v2.2.1
- v2.2.10
- v2.2.2
- v2.2.3
- v2.2.4
- v2.2.5
- v2.2.6
- v2.2.7
- v2.2.8
- v2.2.9
- v2.3.0
- v2.3.1
- v2.3.2
- v2.3.3
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- Affected ranges
- ECOSYSTEM: < 2.3.10
Update to 2.3.10