p PatchFirst

CVE-2026-21872

CVE-2026-21872 · NiceGUI apps are vulnerable to XSS which uses `ui.sub_pages` and render arbitrary user-provided links

This page contains facts from public vulnerability sources. Check the original advisory before updating.

NiceGUI is a Python-based UI framework. From versions 2.22.0 to 3.4.1, an unsafe implementation in the click event listener used by ui.sub_pages, combined with attacker-controlled link rendering on the page, causes XSS when the user actively clicks on the link. This issue has been patched in version 3.5.0.

CVSS 6.1 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • nicegui

    Versions
    • >= 2.22.0, < 3.5.0: Affected

    No fix published

  • nicegui PyPI

    Versions
    • 2.22.0
    • 2.22.1
    • 2.22.2
    • 2.23.0
    • 2.23.1
    • 2.23.2
    • 2.23.3
    • 2.24.0
    • 2.24.1
    • 2.24.2
    • 3.0.0
    • 3.0.0rc1
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.2.0
    • 3.3.0
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 2.22.0, < 3.5.0

    Update to 3.5.0

Original sources

Check your server →