p PatchFirst

CVE-2026-21893

CVE-2026-21893 · n8n Vulnerable to Command Injection in Community Package Installation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

n8n is an open source workflow automation platform. From version 0.187.0 to before 1.120.3, a command injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. This issue has been patched in version 1.120.3.

CVSS 9.4 · Critical · EPSS 1.6% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n8n

    Versions
    • >= 0.187.0, < 1.120.3: Affected

    No fix published

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 0.187.0, < 1.120.3

    Update to 1.120.3

Original sources

Check your server →