p PatchFirst

CVE-2026-21896

CVE-2026-21896 · Kirby is missing permission checks in the content changes API

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Kirby is an open-source content management system. From versions 5.0.0 to 5.2.1, Kirby is missing permission checks in the content changes API. This vulnerability affects all Kirby sites where user permissions are configured to prevent specific role(s) from performing write actions, specifically by disabling the update permission with the intent to prevent modifications to site content. This vulnerability does not affect those who have not altered the deviated from default user permissions. This issue has been patched in version 5.2.2.

CVSS 5.8 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • kirby

    Versions
    • >= 5.0.0, < 5.2.2: Affected

    No fix published

  • getkirby/cms Packagist

    Versions
    • 5.0.0
    • 5.0.1
    • 5.0.2
    • 5.0.3
    • 5.0.4
    • 5.1.0
    • 5.1.0-rc.1
    • 5.1.1
    • 5.1.2
    • 5.1.3
    • 5.1.4
    • 5.2.0
    • 5.2.0-rc.1
    • 5.2.1
    Affected ranges
    • ECOSYSTEM: ≥ 5.0.0, < 5.2.2

    Update to 5.2.2

Original sources

Check your server →