p PatchFirst

CVE-2026-22251

CVE-2026-22251 · wlc may leak API keys due to an insecure API key configuration

This page contains facts from public vulnerability sources. Check the original advisory before updating.

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, wlc supported providing unscoped API keys in the setting. This practice was discouraged for years, but the code was never removed. This might cause the API key to be leaked to different servers.

CVSS 5.3 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • wlc

    Versions
    • < 1.17.0: Affected

    No fix published

  • wlc Debian:12

    Versions
    • 1.13-2
    • 1.14-1
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    • 1.17.2-1
    • 2.0.0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wlc Debian:13

    Versions
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    • 1.17.2-1
    • 2.0.0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wlc Debian:14

    Versions
    • 1.15-1
    • 1.15-2
    • 1.16.1-1
    Affected ranges
    • ECOSYSTEM: < 1.17.2-1

    Update to 1.17.2-1

  • wlc PyPI

    Versions
    • 0.0
    • 0.1
    • 0.10
    • 0.2
    • 0.3
    • 0.4
    • 0.5
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 1.0
    • 1.1
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7
    • 1.8
    • 1.9
    Affected ranges
    • ECOSYSTEM: < 1.17.0

    Update to 1.17.0

  • wlc Ubuntu:Pro:18.04:LTS

    Versions
    • 0.8-1
    Affected ranges
    • ECOSYSTEM: < 0.8-1ubuntu0.1~esm1

    Update to 0.8-1ubuntu0.1~esm1

  • wlc Ubuntu:Pro:20.04:LTS

    Versions
    • 1.1-1
    • 1.2-1
    Affected ranges
    • ECOSYSTEM: < 1.2-1ubuntu0.20.04.1~esm1

    Update to 1.2-1ubuntu0.20.04.1~esm1

  • wlc Ubuntu:Pro:22.04:LTS

    Versions
    • 1.2-1
    Affected ranges
    • ECOSYSTEM: < 1.2-1ubuntu0.22.04.1~esm1

    Update to 1.2-1ubuntu0.22.04.1~esm1

  • wlc Ubuntu:Pro:24.04:LTS

    Versions
    • 1.13-2
    Affected ranges
    • ECOSYSTEM: < 1.13-2ubuntu0.1~esm1

    Update to 1.13-2ubuntu0.1~esm1

  • wlc Ubuntu:25.10

    Versions
    • 1.15-1
    • 1.15-2
    Affected ranges
    • ECOSYSTEM: < 1.15-2ubuntu0.1

    Update to 1.15-2ubuntu0.1

  • wlc Ubuntu:26.10

    Versions
    • 1.16.1-1
    • 2.0.0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wlc Ubuntu:26.04:LTS

    Versions
    • 1.15-2
    • 1.16.1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →