p PatchFirst

CVE-2026-22773

CVE-2026-22773 · vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous dimensions

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.

CVSS 6.5 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • >= 0.6.4, < 0.12.0: Affected

    No fix published

  • vllm PyPI

    Versions
    • 0.10.0
    • 0.10.1
    • 0.10.1.1
    • 0.10.2
    • 0.11.0
    • 0.11.1
    • 0.11.2
    • 0.6.4
    • 0.6.4.post1
    • 0.6.5
    • 0.6.6
    • 0.6.6.post1
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.5.post1
    • 0.9.0
    • 0.9.0.1
    • 0.9.1
    • 0.9.2
    Affected ranges
    • ECOSYSTEM: ≥ 0.6.4, < 0.12.0

    Update to 0.12.0

Original sources

Check your server →