p PatchFirst

CVE-2026-22774

CVE-2026-22774 · devalue vulnerable to denial of service due to memory exhaustion in devalue.parse

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the typed array hydration expecting an ArrayBuffer as input, but not checking the assumption before creating the typed array. This vulnerability is fixed in 5.6.2.

CVSS 7.5 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • devalue

    Versions
    • >= 5.3.0, < 5.6.2: Affected

    No fix published

  • devalue npm

    Affected ranges
    • SEMVER: ≥ 5.3.0, < 5.6.2

    Update to 5.6.2

Original sources

Check your server →