p PatchFirst

CVE-2026-2361

CVE-2026-2361 · Improper search_path protection in PostgreSQL Anonymizer 2.5 allows any user with create privilege to gain superuser privileges

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.get_tablesample_ratio function is then called, the malicious code is executed with superuser privileges. This privilege elevation can be exploited by users having the CREATE privilege in PostgreSQL 15 and later. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version because the creation permission on the public schema is granted by default. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions

CVSS 8.0 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • postgresql anonymizer

    Versions
    • ≥ 1, < 3.0.1: Affected (rpm)

    Update to 3.0.1

  • postgresql-9.3 Ubuntu:Pro:14.04:LTS

    Versions
    • 9.3.1-1
    • 9.3.2-1
    • 9.3.2-1ubuntu1
    • 9.3.2-1ubuntu2
    • 9.3.3-1
    • 9.3.3-1bzr1
    • 9.3.3-1bzr2
    • 9.3.4-1
    • 9.3.5-0ubuntu0.14.04.1
    • 9.3.6-0ubuntu0.14.04
    • 9.3.7-0ubuntu0.14.04
    • 9.3.8-0ubuntu0.4.04
    • 9.3.9-0ubuntu0.14.04
    • 9.3.10-0ubuntu0.14.04
    • 9.3.11-0ubuntu0.14.04
    • 9.3.12-0ubuntu0.14.04
    • 9.3.13-0ubuntu0.14.04
    • 9.3.14-0ubuntu0.14.04
    • 9.3.15-0ubuntu0.14.04
    • 9.3.16-0ubuntu0.14.04
    • 9.3.17-0ubuntu0.14.04
    • 9.3.18-0ubuntu0.14.04.1
    • 9.3.19-0ubuntu0.14.04
    • 9.3.20-0ubuntu0.14.04
    • 9.3.21-0ubuntu0.14.04
    • 9.3.22-0ubuntu0.14.04
    • 9.3.23-0ubuntu0.14.04
    • 9.3.24-0ubuntu0.14.04
    • 9.3.24-0ubuntu0.14.04+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →