CVE-2026-23897
CVE-2026-23897 · Apollo Server is vulnerable to denial of service with `startStandaloneServer`
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.
CVSS 7.5 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
apollo-server
- Versions
- >= 2.0.0, <= 3.13.0: Affected
- >= 4.2.0, < 4.13.0: Affected
- >= 5.0.0, < 5.4.0: Affected
No fix published
apollo-server npm
- Affected ranges
- SEMVER: ≥ 2.0.0, ≤ 3.13.0
No fix published
@apollo/server npm
- Affected ranges
- SEMVER: ≥ 4.2.0, < 4.13.0
Update to 4.13.0
@apollo/server npm
- Affected ranges
- SEMVER: ≥ 5.0.0, < 5.4.0
Update to 5.4.0
Original sources
- https://github.com/apollographql/apollo-server/security/advisories/GHSA-mp6q-xf9x-fwf7
- https://github.com/apollographql/apollo-server/commit/d25a5bdc377826ad424fcf7f8d1d062055911643
- https://github.com/apollographql/apollo-server/commit/e9d49d163a86b8a33be56ed27c494b9acd5400a4
- https://nvd.nist.gov/vuln/detail/CVE-2026-23897