CVE-2026-23947
CVE-2026-23947 · Orval MCP client is vulnerable to code injection via unsanitized x-enum-descriptions in enum generation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions prior to 7.19.0 until 8.0.2 are vulnerable to arbitrary code execution in environments consuming generated clients. This issue is similar in nature to CVE-2026-22785, but affects a different code path in @orval/core that was not addressed by CVE-2026-22785's fix. The vulnerability allows untrusted OpenAPI specifications to inject arbitrary TypeScript/JavaScript code into generated clients via the x-enumDescriptions field, which is embedded without proper escaping in getEnumImplementation(). I have confirmed that the injection occurs during const enum generation and results in executable code within the generated schema files. Orval 7.19.0 and 8.0.2 contain a fix for the issue.
CVSS 9.3 · Critical · EPSS 0.8% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
orval
- Versions
- >= 8.0.0-rc.0, < 8.0.2: Affected
- < 7.19.0: Affected
No fix published
@orval/core npm
- Affected ranges
- SEMVER: ≥ 8.0.0-rc.0, < 8.0.2
Update to 8.0.2
@orval/core npm
- Affected ranges
- SEMVER: < 7.19.0
Update to 7.19.0