CVE-2026-24046
CVE-2026-24046 · Backstage has a Possible Symlink Path Traversal in Scaffolder Actions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Backstage is an open framework for building developer portals. Multiple Scaffolder actions and archive extraction utilities were vulnerable to symlink-based path traversal attacks. An attacker with access to create and execute Scaffolder templates could exploit symlinks to read arbitrary files via the `debug:log` action by creating a symlink pointing to sensitive files (e.g., `/etc/passwd`, configuration files, secrets); delete arbitrary files via the `fs:delete` action by creating symlinks pointing outside the workspace, and write files outside the workspace via archive extraction (tar/zip) containing malicious symlinks. This affects any Backstage deployment where users can create or execute Scaffolder templates. This vulnerability is fixed in `@backstage/backend-defaults` versions 0.12.2, 0.13.2, 0.14.1, and 0.15.0; `@backstage/plugin-scaffolder-backend` versions 2.2.2, 3.0.2, and 3.1.1; and `@backstage/plugin-scaffolder-node` versions 0.11.2 and 0.12.3. Users should upgrade to these versions or later. Some workarounds are available. Follow the recommendation in the Backstage Threat Model to limit access to creating and updating templates, restrict who can create and execute Scaffolder templates using the permissions framework, audit existing templates for symlink usage, and/or run Backstage in a containerized environment with limited filesystem access.
CVSS 7.1 · High · EPSS 0.5% · Public exploit · Fix available
- Published
- Updated
Stack: node
Affected products and versions
backstage
- Versions
- @backstage/backend-defaults < 0.12.2: Affected
- @backstage/backend-defaults >= 0.13.0, < 0.13.2: Affected
- @backstage/backend-defaults >= 0.14.0, < 0.14.1: Affected
- @backstage/plugin-scaffolder-backend < 2.2.2: Affected
- @backstage/plugin-scaffolder-backend >= 3.0.0, < 3.0.2: Affected
- @backstage/plugin-scaffolder-backend >= 3.1.0, < 3.1.1: Affected
- @backstage/plugin-scaffolder-node < 0.11.2: Affected
- @backstage/plugin-scaffolder-node >= 0.12.0, < 0.12.3: Affected
No fix published
@backstage/backend-defaults npm
- Affected ranges
- SEMVER: < 0.12.2
Update to 0.12.2
@backstage/backend-defaults npm
- Affected ranges
- SEMVER: ≥ 0.13.0, < 0.13.2
Update to 0.13.2
@backstage/backend-defaults npm
- Affected ranges
- SEMVER: ≥ 0.14.0, < 0.14.1
Update to 0.14.1
@backstage/plugin-scaffolder-backend npm
- Affected ranges
- SEMVER: < 2.2.2
Update to 2.2.2
@backstage/plugin-scaffolder-backend npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.0.2
Update to 3.0.2
@backstage/plugin-scaffolder-backend npm
- Affected ranges
- SEMVER: ≥ 3.1.0, < 3.1.1
Update to 3.1.1
@backstage/plugin-scaffolder-node npm
- Affected ranges
- SEMVER: < 0.11.2
Update to 0.11.2
@backstage/plugin-scaffolder-node npm
- Affected ranges
- SEMVER: ≥ 0.12.0, < 0.12.3
Update to 0.12.3
Original sources
- https://github.com/backstage/backstage/security/advisories/GHSA-rq6q-wr2q-7pgp
- https://github.com/backstage/backstage/commit/c641c147ab371a9a8a2f5f67fdb7cb9c97ef345d
- https://access.redhat.com/security/cve/CVE-2026-24046
- https://bugzilla.redhat.com/show_bug.cgi?id=2431878
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24046.json
- https://access.redhat.com/errata/RHSA-2026:6174
- https://access.redhat.com/errata/RHSA-2026:6802
- https://nvd.nist.gov/vuln/detail/CVE-2026-24046