CVE-2026-24734
CVE-2026-24734 · Apache Tomcat Native, Apache Tomcat: OCSP revocation bypass
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
CVSS 7.4 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache tomcat native
- Versions
- ≥ 1.1.23, ≤ 1.1.34: Affected (semver)
- ≥ 1.2.0, ≤ 1.2.39: Affected (semver)
- ≥ 1.3.0, ≤ 1.3.4: Affected (semver)
- ≥ 2.0.0, ≤ 2.0.11: Affected (semver)
No fix published
apache tomcat
- Versions
- ≥ 11.0.0-M1, ≤ 11.0.17: Affected (semver)
- ≥ 10.1.0-M7, ≤ 10.1.51: Affected (semver)
- ≥ 9.0.83, ≤ 9.0.114: Affected (semver)
- ≥ 0, ≤ 8.5.100: Not affected (semver)
No fix published
tomcat10 Debian:12
- Versions
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.34-0+deb12u1
- 10.1.34-0+deb12u2
- 10.1.34-1
- 10.1.35-1
- 10.1.40-1
- 10.1.40-1~bpo12+1
- 10.1.46-1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Affected ranges
- ECOSYSTEM: < 10.1.52-1~deb12u1
Update to 10.1.52-1~deb12u1
tomcat10 Debian:13
- Versions
- 10.1.40-1
- 10.1.46-1
- 10.1.52-1~deb12u1
- Affected ranges
- ECOSYSTEM: < 10.1.52-1~deb13u1
Update to 10.1.52-1~deb13u1
tomcat10 Debian:14
- Versions
- 10.1.40-1
- 10.1.46-1
- 10.1.52-1~deb12u1
- 10.1.52-1~deb13u1
- Affected ranges
- ECOSYSTEM: < 10.1.52-1
Update to 10.1.52-1
tomcat11 Debian:13
- Versions
- 11.0.11-1
- 11.0.15-1
- 11.0.15-1~deb13u1
- 11.0.18-1
- 11.0.21-1
- 11.0.6-1
- Affected ranges
- ECOSYSTEM: < 11.0.22-1~deb13u1
Update to 11.0.22-1~deb13u1
tomcat11 Debian:14
- Versions
- 11.0.11-1
- 11.0.15-1
- 11.0.15-1~deb13u1
- 11.0.6-1
- Affected ranges
- ECOSYSTEM: < 11.0.18-1
Update to 11.0.18-1
tomcat9 Debian:12
- Affected ranges
- ECOSYSTEM: < 9.0.70-2
Update to 9.0.70-2
tomcat9 Debian:13
- Affected ranges
- ECOSYSTEM: < 9.0.70-2
Update to 9.0.70-2
tomcat9 Debian:14
- Affected ranges
- ECOSYSTEM: < 9.0.70-2
Update to 9.0.70-2
tomcat10 Ubuntu:24.04:LTS
- Versions
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- 10.1.16-1ubuntu0.1~esm2
- 10.1.16-1ubuntu0.1~esm3
- 10.1.16-1ubuntu0.1~esm4
- 10.1.55-1ubuntu2~24.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat10 Ubuntu:25.10
- Versions
- 10.1.35-1
- 10.1.40-1
- 10.1.40-1ubuntu1
- 10.1.40-1ubuntu1.25.10.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat11 Ubuntu:25.10
- Versions
- 11.0.6-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat9 Ubuntu:25.10
- Versions
- 9.0.70-2ubuntu1.1
- 9.0.70-2ubuntu2
- 9.0.70-2ubuntu3
- 9.0.95-1ubuntu1
- 9.0.95-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
tomcat10 Ubuntu:26.04:LTS
- Versions
- 10.1.40-1ubuntu1
- 10.1.40-1ubuntu1.26.04.1
- 10.1.55-1ubuntu2~26.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://lists.apache.org/thread/292dlmx3fz1888v6v16221kpozq56gml
- https://access.redhat.com/security/cve/CVE-2026-24734
- https://bugzilla.redhat.com/show_bug.cgi?id=2440426
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24734.json
- https://access.redhat.com/errata/RHSA-2026:5611
- https://access.redhat.com/errata/RHSA-2026:19054
- https://access.redhat.com/errata/RHSA-2026:36790
- https://access.redhat.com/errata/RHSA-2026:26323
- https://access.redhat.com/errata/RHSA-2026:8334
- https://access.redhat.com/errata/RHSA-2026:6569
- https://access.redhat.com/errata/RHSA-2026:5612
- https://nvd.nist.gov/vuln/detail/CVE-2026-24734