p PatchFirst

CVE-2026-24771

CVE-2026-24771 · Hono has a Cross-site Scripting vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Hono is a Web application framework that provides support for any JavaScript runtime. Prior to version 4.11.7, a Cross-Site Scripting (XSS) vulnerability exists in the `ErrorBoundary` component of the hono/jsx library. Under certain usage patterns, untrusted user-controlled strings may be rendered as raw HTML, allowing arbitrary script execution in the victim's browser. Version 4.11.7 patches the issue.

CVSS 4.7 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • hono

    Versions
    • < 4.11.7: Affected

    No fix published

  • hono npm

    Affected ranges
    • SEMVER: < 4.11.7

    Update to 4.11.7

Original sources

Check your server →