p PatchFirst

CVE-2026-25128

CVE-2026-25128 · fast-xml-parser has RangeError DoS Numeric Entities Bug

This page contains facts from public vulnerability sources. Check the original advisory before updating.

fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. In versions 5.0.9 through 5.3.3, a RangeError vulnerability exists in the numeric entity processing of fast-xml-parser when parsing XML with out-of-range entity code points (e.g., `�` or `�`). This causes the parser to throw an uncaught exception, crashing any application that processes untrusted XML input. Version 5.3.4 fixes the issue.

CVSS 7.5 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • fast-xml-parser

    Versions
    • >= 5.0.9, <= 5.3.3: Affected

    No fix published

  • fast-xml-parser npm

    Affected ranges
    • SEMVER: ≥ 5.0.9, < 5.3.4

    Update to 5.3.4

  • node-webfont Ubuntu:24.04:LTS

    Versions
    • 11.4.0+dfsg2+~cs35.7.26-7ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-webfont Ubuntu:25.10

    Versions
    • 11.4.0+dfsg2+~cs35.7.26-10
    • 11.4.0+dfsg2+~cs35.7.26-13ubuntu2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-webfont Ubuntu:26.10

    Versions
    • 11.4.0+dfsg2+~cs35.7.26-18
    • 11.4.0+dfsg2+~cs35.7.26-19
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • node-webfont Ubuntu:26.04:LTS

    Versions
    • 11.4.0+dfsg2+~cs35.7.26-13ubuntu2
    • 11.4.0+dfsg2+~cs35.7.26-14
    • 11.4.0+dfsg2+~cs35.7.26-15
    • 11.4.0+dfsg2+~cs35.7.26-16build1
    • 11.4.0+dfsg2+~cs35.7.26-18
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →