p PatchFirst

CVE-2026-25610

CVE-2026-25610 · Invalid $geoNear index hint may cause server crash

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An authorized user may trigger a server crash by running a $geoNear pipeline with certain invalid index hints.

CVSS 7.1 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • mongodb server

    Versions
    • ≥ 8.0, < 8.0.13: Affected (semver)
    • ≥ 7.0, < 7.0.29: Affected (semver)

    Update to 7.0.29; Update to 8.0.13

  • mongodb Ubuntu:Pro:18.04:LTS

    Versions
    • 1:3.4.7-1
    • 1:3.4.7-1ubuntu1
    • 1:3.4.7-1ubuntu2
    • 1:3.4.7-1ubuntu4
    • 1:3.4.14-3ubuntu1
    • 1:3.4.14-3ubuntu2
    • 1:3.6.3-0ubuntu1
    • 1:3.6.3-0ubuntu1.1
    • 1:3.6.3-0ubuntu1.3
    • 1:3.6.3-0ubuntu1.4
    • 1:3.6.3-0ubuntu1.4+esm1
    • 1:3.6.3-0ubuntu1.4+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:20.04:LTS

    Versions
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →