CVE-2026-26030
CVE-2026-26030 · Microsoft Semantic Kernel InMemoryVectorStore filter functionality vulnerable to remote code execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Semantic Kernel, Microsoft's semantic kernel Python SDK, has a remote code execution vulnerability in versions prior to 1.39.4, specifically within the `InMemoryVectorStore` filter functionality. The problem has been fixed in version `python-1.39.4`. Users should upgrade this version or higher. As a workaround, avoid using `InMemoryVectorStore` for production scenarios.
CVSS 10.0 · Critical · EPSS 3.9% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
semantic-kernel
- Versions
- < 1.39.4: Affected
No fix published
semantic-kernel PyPI
- Versions
- 0.0.1.dev0
- 0.1.0.dev0
- 0.2.0.dev0
- 0.2.1.dev0
- 0.2.2.dev0
- 0.2.3.dev0
- 0.2.4.dev0
- 0.2.5.dev0
- 0.2.6.dev0
- 0.2.7.dev0
- 0.2.8.dev0
- 0.2.9.dev0
- 0.3.0.dev0
- 0.3.1.dev0
- 0.3.10.dev0
- 0.3.11.dev0
- 0.3.12.dev0
- 0.3.13.dev0
- 0.3.14.dev0
- 0.3.15.dev0
- 0.3.2.dev0
- 0.3.3.dev0
- 0.3.4.dev0
- 0.3.5.dev0
- 0.3.6.dev0
- 0.3.7.dev0
- 0.3.8.dev0
- 0.3.9.dev0
- 0.4.0.dev0
- 0.4.1.dev0
- 0.4.2.dev0
- 0.4.3.dev0
- 0.4.4.dev0
- 0.4.5.dev0
- 0.4.6.dev0
- 0.4.7.dev0
- 0.5.0.dev0
- 0.5.1.dev0
- 0.9.0b1
- 0.9.1b1
- 0.9.2b1
- 0.9.3b1
- 0.9.4b1
- 0.9.5b1
- 0.9.6b1
- 0.9.7b1
- 0.9.8b1
- 0.9.9b1
- 1.0.0
- 1.0.0rc1
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.1.0
- 1.1.1
- 1.1.2
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.1
- 1.13.0
- 1.14.0
- 1.15.0
- 1.16.0
- 1.17.0
- 1.17.1
- 1.18.0
- 1.18.1
- 1.18.2
- 1.19.0
- 1.2.0
- 1.20.0
- 1.21.0
- 1.21.1
- 1.21.2
- 1.21.3
- 1.22.0
- 1.22.1
- 1.23.0
- 1.23.1
- 1.24.0
- 1.24.1
- 1.25.0
- 1.26.0
- 1.26.1
- 1.27.0
- 1.27.1
- 1.27.2
- 1.28.0
- 1.28.1
- 1.29.0
- 1.3.0
- 1.30.0
- 1.31.0
- 1.32.0
- 1.32.1
- 1.32.2
- 1.33.0
- 1.34.0
- 1.35.0
- 1.35.1
- 1.35.2
- 1.35.3
- 1.36.0
- 1.36.1
- 1.36.2
- 1.37.0
- 1.37.1
- 1.38.0
- 1.39.0
- 1.39.1
- 1.39.2
- 1.39.3
- 1.4.0
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 1.8.2
- 1.8.3
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.39.4
Update to 1.39.4