p PatchFirst

CVE-2026-26063

CVE-2026-26063 · CediPay Affected by Improper Input Validation in Payment Processing

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CediPay is a crypto-to-fiat app for the Ghanaian market. A vulnerability in CediPay prior to version 1.2.3 allows attackers to bypass input validation in the transaction API. The issue has been fixed in version 1.2.3. If upgrading is not immediately possible, restrict API access to trusted networks or IP ranges; enforce strict input validation at the application layer; and/or monitor transaction logs for anomalies or suspicious activity. These mitigations reduce exposure but do not fully eliminate the vulnerability.

CVSS 8.8 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • cedipay

    Versions
    • < 1.2.3: Affected

    No fix published

  • cedipay-core npm

    Affected ranges
    • SEMVER: < 1.2.3

    Update to 1.2.3

Original sources

Check your server →