CVE-2026-26318
CVE-2026-26318 · systeminformation has Command Injection via Unsanitized `locate` Output in `versions()`
This page contains facts from public vulnerability sources. Check the original advisory before updating.
systeminformation is a System and OS information library for node.js. Versions prior to 5.31.0 are vulnerable to command injection via unsanitized `locate` output in `versions()`. Version 5.31.0 fixes the issue.
CVSS 8.8 · High · EPSS 1.3% · Fix available
- Published
- Updated
Affected products and versions
systeminformation
- Versions
- < 5.31.0: Affected
No fix published
jupyterlab Debian:13
- Versions
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- 4.0.11+ds5+~cs11.25.27-1
- 4.0.13+ds1+~2.0.1+~cs1.4.4-1
- 4.1.3+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-1
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-2
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-3
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-4
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-5
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-6
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-7
- 4.1.8+ds1+~2.0.1+~0.15.3+~cs1.4.4-8
- 4.4.1+ds1+~3.0.5+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-2
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-5
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-6
- 4.4.8+ds1+~3.1.0+~0.16.6+~cs1.4.4-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyterlab Debian:14
- Versions
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- 4.0.11+ds2+~cs11.25.27-1
- 4.0.11+ds2+~cs11.25.27-3
- 4.0.11+ds3+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-1
- 4.0.11+ds4+~cs11.25.27-2
- 4.0.11+ds4+~cs11.25.27-3
- 4.0.11+ds4+~cs11.25.27-4
- Affected ranges
- ECOSYSTEM: < 4.0.11+ds5+~cs11.25.27-1
Update to 4.0.11+ds5+~cs11.25.27-1
systeminformation npm
- Affected ranges
- SEMVER: < 5.31.0
Update to 5.31.0
jupyterlab Ubuntu:25.10
- Versions
- 4.0.11+ds1+~cs11.25.27-5
- 4.0.11+ds1+~cs11.25.27-6
- 4.0.11+ds1+~cs11.25.27-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyterlab Ubuntu:26.10
- Versions
- 4.0.11+ds1+~cs11.25.27-9
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-systeminformation Ubuntu:26.10
- Versions
- 5.31.6-4
- 5.31.7-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jupyterlab Ubuntu:26.04:LTS
- Versions
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-5vv4-hvf7-2h46
- https://github.com/sebhildebrandt/systeminformation/commit/b67d3715eec881038ccbaace2f2711419ac3e107
- https://access.redhat.com/security/cve/CVE-2026-26318
- https://bugzilla.redhat.com/show_bug.cgi?id=2441124
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-26318.json
- https://nvd.nist.gov/vuln/detail/CVE-2026-26318