p PatchFirst

CVE-2026-26345

CVE-2026-26345 · SPIP < 4.4.8 Cross-Site Scripting in Public Area

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SPIP before 4.4.8 contains a stored cross-site scripting (XSS) vulnerability in the public area triggered in certain edge-case usage patterns. The echapper_html_suspect() function does not adequately sanitize user-controlled content, allowing authenticated users with content-editing privileges (e.g., author-level roles and above) to inject malicious scripts. The injected payload may be rendered across multiple pages within the framework and execute in the browser context of other users, including administrators. Successful exploitation can allow attackers to perform actions in the security context of the victim user, including unauthorized modification of application state. This vulnerability is not mitigated by the SPIP security screen.

CVSS 8.6 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • spip

    Versions
    • ≥ 4.4.0, < 4.4.8: Affected (semver)

    Update to 4.4.8

  • spip Debian:13

    Versions
    • 4.4.10+dfsg-1
    • 4.4.3+dfsg-1
    • 4.4.3+dfsg-1+deb13u1
    • 4.4.4+dfsg-1
    • 4.4.5+dfsg-1
    • 4.4.6+dfsg-1
    • 4.4.7+dfsg-1
    • 4.4.8+dfsg-1
    • 4.4.9+dfsg-1
    Affected ranges
    • ECOSYSTEM: < 4.4.11+dfsg-0+deb13u1

    Update to 4.4.11+dfsg-0+deb13u1

  • spip Debian:14

    Versions
    • 4.4.3+dfsg-1
    • 4.4.4+dfsg-1
    • 4.4.5+dfsg-1
    • 4.4.6+dfsg-1
    • 4.4.7+dfsg-1
    • 4.4.8+dfsg-1
    Affected ranges
    • ECOSYSTEM: < 4.4.9+dfsg-1

    Update to 4.4.9+dfsg-1

  • spip Ubuntu:Pro:16.04:LTS

    Versions
    • 3.0.20-1
    • 3.0.21-1
    • 3.0.21-1ubuntu1
    • 3.0.21-1ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:Pro:18.04:LTS

    Versions
    • 3.1.4-3
    • 3.1.4-4~deb9u3build0.18.04.1
    • 3.1.4-4~deb9u5build0.18.04.1
    • 3.1.4-4~deb9u5ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:Pro:20.04:LTS

    Versions
    • 3.2.4-1
    • 3.2.5-1
    • 3.2.7-1
    • 3.2.7-1ubuntu0.1
    • 3.2.7-1ubuntu0.1+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:22.04:LTS

    Versions
    • 3.2.11-3
    • 3.2.12-1
    • 4.0.2-1
    • 4.0.4-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:24.04:LTS

    Versions
    • 4.1.11+dfsg-1
    • 4.1.12+dfsg-1
    • 4.1.13+dfsg-1
    • 4.1.15+dfsg-1
    • 4.2.9+dfsg-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:25.10

    Versions
    • 4.3.8+dfsg-1
    • 4.4.3+dfsg-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • spip Ubuntu:26.04:LTS

    Versions
    • 4.4.3+dfsg-1
    • 4.4.6+dfsg-1
    • 4.4.7+dfsg-1
    • 4.4.8+dfsg-1
    • 4.4.9+dfsg-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →