CVE-2026-27448
CVE-2026-27448 · pyOpenSSL allows TLS connection bypass via unhandled callback exception in set_tlsext_servername_callback
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 0.14.0 and prior to version 26.0.0, if a user provided callback to `set_tlsext_servername_callback` raised an unhandled exception, this would result in a connection being accepted. If a user was relying on this callback for any security-sensitive behavior, this could allow bypassing it. Starting in version 26.0.0, unhandled exceptions now result in rejecting the connection.
CVSS 1.7 · Low · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
pyopenssl
- Versions
- >= 0.14.0, < 26.0.0: Affected
No fix published
pyopenssl Debian:12
- Versions
- 23.0.0-1
- 23.2.0-1
- 24.0.0-1
- 24.0.0-2
- 24.0.0-3
- 24.0.0-4
- 24.0.0-5
- 24.1.0-1
- 24.2.1-1
- 24.3.0-1
- 25.0.0-1
- 25.1.0-1
- 25.1.0-2
- 25.3.0-1
- 25.3.0-2
- 26.0.0-1
- 26.1.0-1
- 26.2.0-1
- 26.2.0-1~exp1
- 26.3.0-1
- 26.3.0-1~exp1
- 26.4.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pyopenssl Debian:13
- Versions
- 25.0.0-1
- Affected ranges
- ECOSYSTEM: < 25.0.0-1+deb13u1
Update to 25.0.0-1+deb13u1
pyopenssl Debian:14
- Versions
- 25.0.0-1
- 25.1.0-1
- 25.1.0-2
- 25.3.0-1
- 25.3.0-2
- Affected ranges
- ECOSYSTEM: < 26.0.0-1
Update to 26.0.0-1
pyopenssl PyPI
- Versions
- 0.14
- 0.15
- 0.15.1
- 16.0.0
- 16.1.0
- 16.2.0
- 17.0.0
- 17.1.0
- 17.2.0
- 17.3.0
- 17.4.0
- 17.5.0
- 18.0.0
- 19.0.0
- 19.1.0
- 20.0.0
- 20.0.1
- 21.0.0
- 22.0.0
- 22.1.0
- 23.0.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 24.0.0
- 24.1.0
- 24.2.1
- 24.3.0
- 25.0.0
- 25.1.0
- 25.2.0
- 25.3.0
- Affected ranges
- ECOSYSTEM: ≥ 0.14.0, < 26.0.0
Update to 26.0.0
pyopenssl PyPI
- Versions
- 0.14
- 0.15
- 0.15.1
- 16.0.0
- 16.1.0
- 16.2.0
- 17.0.0
- 17.1.0
- 17.2.0
- 17.3.0
- 17.4.0
- 17.5.0
- 18.0.0
- 19.0.0
- 19.1.0
- 20.0.0
- 20.0.1
- 21.0.0
- 22.0.0
- 22.1.0
- 23.0.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 24.0.0
- 24.1.0
- 24.2.1
- 24.3.0
- 25.0.0
- 25.1.0
- 25.2.0
- 25.3.0
- Affected ranges
- ECOSYSTEM: ≥ 0.14, < 26.0.0
Update to 26.0.0
pyopenssl Ubuntu:Pro:16.04:LTS
- Versions
- 0.15.1-2build1
- 0.15.1-2ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 0.15.1-2ubuntu0.2+esm1
Update to 0.15.1-2ubuntu0.2+esm1
pyopenssl Ubuntu:Pro:18.04:LTS
- Versions
- 16.2.0-1
- 17.5.0-1
- 17.5.0-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 17.5.0-1ubuntu1+esm1
Update to 17.5.0-1ubuntu1+esm1
pyopenssl Ubuntu:Pro:20.04:LTS
- Versions
- 19.0.0-1
- 19.0.0-1build1
- Affected ranges
- ECOSYSTEM: < 19.0.0-1ubuntu0.1~esm1
Update to 19.0.0-1ubuntu0.1~esm1
pyopenssl Ubuntu:22.04:LTS
- Versions
- 20.0.1-1
- 21.0.0-1
- Affected ranges
- ECOSYSTEM: < 21.0.0-1ubuntu0.1
Update to 21.0.0-1ubuntu0.1
pyopenssl Ubuntu:24.04:LTS
- Versions
- 23.0.0-1
- 23.2.0-1
- Affected ranges
- ECOSYSTEM: < 23.2.0-1ubuntu0.1
Update to 23.2.0-1ubuntu0.1
pyopenssl Ubuntu:25.10
- Versions
- 25.0.0-1
- Affected ranges
- ECOSYSTEM: < 25.0.0-1ubuntu0.1
Update to 25.0.0-1ubuntu0.1