p PatchFirst

CVE-2026-27459

CVE-2026-27459 · pyOpenSSL DTLS cookie callback buffer overflow

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 22.0.0 and prior to version 26.0.0, if a user provided callback to `set_cookie_generate_callback` returned a cookie value greater than 256 bytes, pyOpenSSL would overflow an OpenSSL provided buffer. Starting in version 26.0.0, cookie values that are too long are now rejected.

CVSS 7.2 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • pyopenssl

    Versions
    • >= 22.0.0, < 26.0.0: Affected

    No fix published

  • pyopenssl Debian:12

    Versions
    • 23.0.0-1
    • 23.2.0-1
    • 24.0.0-1
    • 24.0.0-2
    • 24.0.0-3
    • 24.0.0-4
    • 24.0.0-5
    • 24.1.0-1
    • 24.2.1-1
    • 24.3.0-1
    • 25.0.0-1
    • 25.1.0-1
    • 25.1.0-2
    • 25.3.0-1
    • 25.3.0-2
    • 26.0.0-1
    • 26.1.0-1
    • 26.2.0-1
    • 26.2.0-1~exp1
    • 26.3.0-1
    • 26.3.0-1~exp1
    • 26.4.0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pyopenssl Debian:13

    Versions
    • 25.0.0-1
    Affected ranges
    • ECOSYSTEM: < 25.0.0-1+deb13u1

    Update to 25.0.0-1+deb13u1

  • pyopenssl Debian:14

    Versions
    • 25.0.0-1
    • 25.1.0-1
    • 25.1.0-2
    • 25.3.0-1
    • 25.3.0-2
    Affected ranges
    • ECOSYSTEM: < 26.0.0-1

    Update to 26.0.0-1

  • pyopenssl PyPI

    Versions
    • 22.0.0
    • 22.1.0
    • 23.0.0
    • 23.1.0
    • 23.1.1
    • 23.2.0
    • 23.3.0
    • 24.0.0
    • 24.1.0
    • 24.2.1
    • 24.3.0
    • 25.0.0
    • 25.1.0
    • 25.2.0
    • 25.3.0
    Affected ranges
    • ECOSYSTEM: ≥ 22.0.0, < 26.0.0

    Update to 26.0.0

  • pyopenssl Ubuntu:24.04:LTS

    Versions
    • 23.0.0-1
    • 23.2.0-1
    Affected ranges
    • ECOSYSTEM: < 23.2.0-1ubuntu0.1

    Update to 23.2.0-1ubuntu0.1

  • pyopenssl Ubuntu:25.10

    Versions
    • 25.0.0-1
    Affected ranges
    • ECOSYSTEM: < 25.0.0-1ubuntu0.1

    Update to 25.0.0-1ubuntu0.1

Original sources

Check your server →