p PatchFirst

CVE-2026-27566

CVE-2026-27566 · OpenClaw < 2026.2.22 - Allowlist Bypass via Wrapper Binary Unwrapping in system.run

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.22 contain an allowlist bypass vulnerability in system.run exec analysis that fails to unwrap env and shell-dispatch wrapper chains. Attackers can route execution through wrapper binaries like env bash to smuggle payloads that satisfy allowlist entries while executing non-allowlisted commands.

CVSS 7.1 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.22: Affected (semver)

    Update to 2026.2.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.22

    Update to 2026.2.22

Original sources

Check your server →