CVE-2026-27606
CVE-2026-27606 · Rollup 4 has Arbitrary File Write via Path Traversal
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Rollup is a module bundler for JavaScript. Versions prior to 2.80.0, 3.30.0, and 4.59.0 of the Rollup module bundler (specifically v4.x and present in current source) is vulnerable to an Arbitrary File Write via Path Traversal. Insecure file name sanitization in the core engine allows an attacker to control output filenames (e.g., via CLI named inputs, manual chunk aliases, or malicious plugins) and use traversal sequences (`../`) to overwrite files anywhere on the host filesystem that the build process has permissions for. This can lead to persistent Remote Code Execution (RCE) by overwriting critical system or user configuration files. Versions 2.80.0, 3.30.0, and 4.59.0 contain a patch for the issue.
CVSS 8.8 · High · EPSS 1.7% · Public exploit · Fix available
- Published
- Updated
Affected products and versions
rollup
- Versions
- < 2.80.0: Affected
- >= 3.0.0, < 3.30.0: Affected
- >= 4.0.0, < 4.59.0: Affected
No fix published
node-rollup Debian:12
- Versions
- 3.15.0-1
- 3.15.0-1+deb12u1
- 3.15.0-2
- 3.28.0-1
- 3.28.0-2
- 3.29.4-1
- 3.29.4-2
- 3.29.4-3
- 3.29.5-1
- 3.29.5-2
- 3.29.5-3
- 3.30.0-1
- 3.30.0-2
- 3.30.0-3
- 3.30.0-4
- 3.30.0-5
- 3.30.0-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Debian:13
- Versions
- 3.29.5-1
- 3.29.5-2
- 3.29.5-3
- 3.30.0-1
- 3.30.0-2
- 3.30.0-3
- 3.30.0-4
- 3.30.0-5
- 3.30.0-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Debian:14
- Versions
- 3.29.5-1
- 3.29.5-2
- 3.29.5-3
- Affected ranges
- ECOSYSTEM: < 3.30.0-1
Update to 3.30.0-1
rollup npm
- Affected ranges
- SEMVER: < 2.80.0
Update to 2.80.0
rollup npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.30.0
Update to 3.30.0
rollup npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.59.0
Update to 4.59.0
node-rollup Ubuntu:20.04:LTS
- Versions
- 0.50.0-6build3
- 0.68.2-2
- 1.12.0-2build2
- 1.12.0-2build3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:22.04:LTS
- Versions
- 2.38.4-1
- 2.42.1-2
- 2.61.1-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:24.04:LTS
- Versions
- 3.28.0-2
- 3.29.4-2
- 3.29.4-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:25.10
- Versions
- 3.29.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:26.10
- Versions
- 3.30.0-1
- 3.30.0-5build5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-rollup Ubuntu:26.04:LTS
- Versions
- 3.29.5-1
- 3.30.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/rollup/rollup/security/advisories/GHSA-mw96-cpmx-2vgc
- https://github.com/rollup/rollup/commit/c60770d7aaf750e512c1b2774989ea4596e660b2
- https://github.com/rollup/rollup/commit/c8cf1f9c48c516285758c1e11f08a54f304fd44e
- https://github.com/rollup/rollup/commit/d6dee5e99bb82aac0bee1df4ab9efbde455452c3
- https://github.com/rollup/rollup/releases/tag/v2.80.0
- https://github.com/rollup/rollup/releases/tag/v3.30.0
- https://github.com/rollup/rollup/releases/tag/v4.59.0
- https://access.redhat.com/security/cve/CVE-2026-27606
- https://bugzilla.redhat.com/show_bug.cgi?id=2442530
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-27606.json
- https://access.redhat.com/errata/RHSA-2026:13512
- https://access.redhat.com/errata/RHSA-2026:13508
- https://access.redhat.com/errata/RHSA-2026:13545
- https://access.redhat.com/errata/RHSA-2026:6174
- https://access.redhat.com/errata/RHSA-2026:6802
- https://access.redhat.com/errata/RHSA-2026:10175
- https://access.redhat.com/errata/RHSA-2026:8483
- https://access.redhat.com/errata/RHSA-2026:5132
- https://access.redhat.com/errata/RHSA-2026:5665
- https://access.redhat.com/errata/RHSA-2026:5649
- https://nvd.nist.gov/vuln/detail/CVE-2026-27606