CVE-2026-27699
CVE-2026-27699 · Basic FTP has Path Traversal Vulnerability in its downloadToDir() method
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The `basic-ftp` FTP client library for Node.js contains a path traversal vulnerability (CWE-22) in versions prior to 5.2.0 in the `downloadToDir()` method. A malicious FTP server can send directory listings with filenames containing path traversal sequences (`../`) that cause files to be written outside the intended download directory. Version 5.2.0 patches the issue.
CVSS 9.1 · Critical · EPSS 0.9% · Fix available
- Published
- Updated
Affected products and versions
basic-ftp
- Versions
- < 5.2.0: Affected
No fix published
node-proxy-agents Debian:13
- Versions
- 0~2024040606-6
- Affected ranges
- ECOSYSTEM: < 0~2024040606-6+deb13u1
Update to 0~2024040606-6+deb13u1
node-proxy-agents Debian:14
- Versions
- 0~2024040606-6
- 0~2025070717-1
- 0~2025070717-2
- 0~2025070717-3
- 0~2025070717-4
- 0~2025070717-5
- 0~2025070717-6
- Affected ranges
- ECOSYSTEM: < 0~2025070717+~cs15.2.7-1
Update to 0~2025070717+~cs15.2.7-1
basic-ftp npm
- Affected ranges
- SEMVER: < 5.2.0
Update to 5.2.0
node-proxy-agents Ubuntu:24.04:LTS
- Versions
- 0~2023071921-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-proxy-agents Ubuntu:25.10
- Versions
- 0~2024040606-5
- 0~2024040606-6
- 0~2025070717-1
- 0~2025070717-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-proxy-agents Ubuntu:26.10
- Versions
- 0~2025070717+~cs15.2.7-1build1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-proxy-agents Ubuntu:26.04:LTS
- Versions
- 0~2025070717-2
- 0~2025070717-6
- 0~2025070717+~cs15.2.7-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published