p PatchFirst

CVE-2026-27893

CVE-2026-27893 · vLLM's hardcoded trust_remote_code=True in NemotronVL and KimiK25 bypasses user security opt-out

This page contains facts from public vulnerability sources. Check the original advisory before updating.

vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when loading sub-components, bypassing the user's explicit `--trust-remote-code=False` security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust. Version 0.18.0 patches the issue.

CVSS 8.8 · High · EPSS 1.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • vllm

    Versions
    • >= 0.10.1, < 0.18.0: Affected

    No fix published

  • vllm PyPI

    Versions
    • 0.10.1
    • 0.10.1.1
    • 0.10.2
    • 0.11.0
    • 0.11.1
    • 0.11.2
    • 0.12.0
    • 0.13.0
    • 0.14.0
    • 0.14.1
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.17.0
    • 0.17.1
    Affected ranges
    • ECOSYSTEM: ≥ 0.10.1, < 0.18.0

    Update to 0.18.0

Original sources

Check your server →