p PatchFirst

CVE-2026-28292

CVE-2026-28292 · simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE

This page contains facts from public vulnerability sources. Check the original advisory before updating.

`simple-git`, an interface for running git commands in any node.js application, has an issue in versions 3.15.0 through 3.32.2 that allows an attacker to bypass two prior CVE fixes (CVE-2022-25860 and CVE-2022-25912) and achieve full remote code execution on the host machine. Version 3.23.0 contains an updated fix for the vulnerability.

CVSS 9.8 · Critical · EPSS 1.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • simple-git

    Versions
    • >= 3.15.0, < 3.32.3: Affected

    No fix published

  • simple-git npm

    Affected ranges
    • SEMVER: ≥ 3.15.0, < 3.32.3

    Update to 3.32.3

Original sources

Check your server →