p PatchFirst

CVE-2026-28452

CVE-2026-28452 · OpenClaw < 2026.2.14 - Denial of Service via Unguarded Archive Extraction in extractArchive

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.14 contain a denial of service vulnerability in the extractArchive function within src/infra/archive.ts that allows attackers to consume excessive CPU, memory, and disk resources through high-expansion ZIP and TAR archives. Remote attackers can trigger resource exhaustion by providing maliciously crafted archive files during install or update operations, causing service degradation or system unavailability.

CVSS 6.7 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.14: Affected (custom)

    Update to 2026.2.14

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.14

    Update to 2026.2.14

  • clawdbot npm

    Affected ranges
    • SEMVER: ≤ 2026.1.24-3

    No fix published

Original sources

Check your server →