p PatchFirst

CVE-2026-28456

CVE-2026-28456 · OpenClaw 2026.1.5 < 2026.2.14 - Arbitrary Code Execution via Unsafe Hook Module Path Handling

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions 2026.1.5 prior to 2026.2.14 contain a vulnerability in the Gateway in which it does not sufficiently constrain configured hook module paths before passing them to dynamic import(), allowing code execution. An attacker with gateway configuration modification access can load and execute unintended local modules in the Node.js process.

CVSS 8.6 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 2026.1.5, < 2026.2.14: Affected (custom)

    Update to 2026.2.14

  • openclaw npm

    Affected ranges
    • SEMVER: ≥ 2026.1.5, < 2026.2.14

    Update to 2026.2.14

Original sources

Check your server →