p PatchFirst

CVE-2026-28470

CVE-2026-28470 · OpenClaw < 2026.2.2 - Exec Allowlist Bypass via Command Substitution in Double Quotes

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.2 contain an exec approvals (must be enabled) allowlist bypass vulnerability that allows attackers to execute arbitrary commands by injecting command substitution syntax. Attackers can bypass the allowlist protection by embedding unescaped $() or backticks inside double-quoted strings to execute unauthorized commands.

CVSS 9.2 · Critical · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.2: Affected (custom)

    Update to 2026.2.2

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.2

    Update to 2026.2.2

Original sources

Check your server →