CVE-2026-28500
CVE-2026-28500 · ONNX Untrusted Model Repository Warnings Suppressed by silent=True in onnx.hub.load() — Silent Supply-Chain Attack
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. In versions up to and including 1.20.1, a security control bypass exists in onnx.hub.load() due to improper logic in the repository trust verification mechanism. While the function is designed to warn users when loading models from non-official sources, the use of the silent=True parameter completely suppresses all security warnings and confirmation prompts. This vulnerability transforms a standard model-loading function into a vector for Zero-Interaction Supply-Chain Attacks. When chained with file-system vulnerabilities, an attacker can silently exfiltrate sensitive files (SSH keys, cloud credentials) from the victim's machine the moment the model is loaded. As of time of publication, no known patched versions are available.
CVSS 8.6 · High · EPSS 0.3% · Fix available
- Published
- Updated
Affected products and versions
onnx
- Versions
- <= 1.20.1: Affected
No fix published
onnx Debian:12
- Versions
- 1.12.0-2
- 1.13.1-1
- 1.13.1-2
- 1.13.1-3
- 1.14.1-1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1~exp1
- 1.16.1-1
- 1.16.2-1
- 1.17.0-1
- 1.17.0-2
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Debian:13
- Versions
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Debian:14
- Versions
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx PyPI
- Versions
- 0.1
- 0.2
- 0.2.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.16.1
- 1.16.2
- 1.17.0
- 1.18.0
- 1.19.0
- 1.19.1
- 1.19.1rc1
- 1.2.1
- 1.2.2
- 1.2.3
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.1
- 1.20.1rc1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.21.0rc1
Update to 1.21.0rc1
onnx Ubuntu:22.04:LTS
- Versions
- 1.7.0+dfsg-3build1
- 1.7.0+dfsg-3build2
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Ubuntu:Pro:24.04:LTS
- Versions
- 1.13.1-3
- 1.13.1-3build1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1build1
- 1.14.1-2.1build2
- 1.14.1-2.1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Ubuntu:25.10
- Versions
- 1.17.0-3build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Ubuntu:26.10
- Versions
- 1.20.0-1
- 1.20.0-6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
onnx Ubuntu:26.04:LTS
- Versions
- 1.17.0-3build1
- 1.20.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/onnx/onnx/security/advisories/GHSA-hqmj-h5c6-369m
- https://github.com/ZeroXJacks/CVEs/blob/main/2026/CVE-2026-28500.md
- https://access.redhat.com/security/cve/CVE-2026-28500
- https://bugzilla.redhat.com/show_bug.cgi?id=2448518
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28500.json
- https://access.redhat.com/errata/RHSA-2026:24977
- https://nvd.nist.gov/vuln/detail/CVE-2026-28500