CVE-2026-2880
CVE-2026-2880 · @fastify/middie has an improper path normalization vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in @fastify/middie versions < 9.2.0 can result in authentication/authorization bypass when using path-scoped middleware (for example, app.use('/secret', auth)). When Fastify router normalization options are enabled (such as ignoreDuplicateSlashes, useSemicolonDelimiter, and related trailing-slash behavior), crafted request paths may bypass middleware checks while still being routed to protected handlers.
CVSS 8.2 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
@fastify/middie
- Versions
- ≥ 0.0.0, < 9.2.0: Affected (semver)
Update to 9.2.0
@fastify/middie npm
- Affected ranges
- SEMVER: < 9.2.0
Update to 9.2.0