CVE-2026-29199
CVE-2026-29199
This page contains facts from public vulnerability sources. Check the original advisory before updating.
phpBB before 3.3.16 is vulnerable to Host Header Injection that can lead to password rest link poisoning. When force_server_vars is disabled, the servers hostname may be extracted from the HTTP Host header which is used to generate the password reset link URL. An attacker who can manipulate the Host header (e.g. through misconfigured host setup or missing header validation by the webserver) can cause password reset emails to contain a link pointing to an attacker-controlled domain, potentially leading to account takeover.
CVSS 8.1 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
phpbb
- Versions
- ≥ 3.0.0, ≤ 3.3.15: Affected (semver)
No fix published
phpbb/phpbb Packagist
- Versions
- 3.0.12
- 3.0.12-RC1
- 3.0.12-RC2
- 3.0.12-RC3
- 3.0.13
- 3.0.13-PL1
- 3.0.13-RC1
- 3.0.14
- 3.0.14-RC1
- 3.1.0
- 3.1.0-RC1
- 3.1.0-RC2
- 3.1.0-RC3
- 3.1.0-RC4
- 3.1.0-RC5
- 3.1.0-RC6
- 3.1.0-a1
- 3.1.0-a2
- 3.1.0-a3
- 3.1.0-b1
- 3.1.0-b2
- 3.1.0-b3
- 3.1.0-b4
- 3.1.1
- 3.1.10
- 3.1.10-RC1
- 3.1.11
- 3.1.11-RC1
- 3.1.12
- 3.1.2
- 3.1.2-RC1
- 3.1.3
- 3.1.3-RC1
- 3.1.3-RC2
- 3.1.4
- 3.1.4-RC1
- 3.1.4-RC2
- 3.1.5
- 3.1.5-RC1
- 3.1.6
- 3.1.6-RC1
- 3.1.7
- 3.1.7-RC1
- 3.1.7-pl1
- 3.1.8
- 3.1.8-RC1
- 3.1.9
- 3.1.9-RC1
- 3.2.0
- 3.2.0-RC1
- 3.2.0-RC2
- 3.2.0-a1
- 3.2.0-b2
- 3.2.1
- 3.2.1-RC1
- 3.2.10
- 3.2.10-RC1
- 3.2.10-RC2
- 3.2.11
- 3.2.2
- 3.2.2-RC1
- 3.2.3
- 3.2.3-RC1
- 3.2.3-RC2
- 3.2.4
- 3.2.4-RC1
- 3.2.5
- 3.2.5-RC1
- 3.2.6
- 3.2.6-RC1
- 3.2.7
- 3.2.7-RC1
- 3.2.8
- 3.2.8-RC1
- 3.2.9
- 3.2.9-RC1
- 3.3.0
- 3.3.0-RC1
- 3.3.0-b1
- 3.3.0-b2
- 3.3.1
- 3.3.1-RC1
- 3.3.10
- 3.3.10-RC1
- 3.3.11
- 3.3.12
- 3.3.12-RC1
- 3.3.13
- 3.3.13-RC1
- 3.3.14
- 3.3.14-RC1
- 3.3.15
- 3.3.15-RC1
- 3.3.16-RC1
- 3.3.2
- 3.3.2-RC1
- 3.3.3
- 3.3.3-RC1
- 3.3.4
- 3.3.4-RC1
- 3.3.5
- 3.3.5-RC1
- 3.3.6
- 3.3.6-RC1
- 3.3.7
- 3.3.8
- 3.3.8-RC1
- 3.3.9
- 3.3.9-RC1
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0, < 3.3.16
Update to 3.3.16
phpbb/phpbb Packagist
- Versions
- 4.0.0-a1
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0-a1, < 4.0.0-a2
Update to 4.0.0-a2