p PatchFirst

CVE-2026-29607

CVE-2026-29607 · OpenClaw < 2026.2.22 - Authorization Bypass via allow-always Wrapper Persistence

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.22 contain an authorization bypass vulnerability in allow-always wrapper persistence that allows attackers to bypass approval checks by persisting wrapper-level allowlist entries instead of validating inner executable intent. Remote attackers can approve benign wrapped system.run commands and subsequently execute different payloads without approval, enabling remote code execution on gateway and node-host execution flows.

CVSS 7.1 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.22: Affected (semver)

    Update to 2026.2.22

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.22

    Update to 2026.2.22

Original sources

Check your server →