p PatchFirst

CVE-2026-29610

CVE-2026-29610 · OpenClaw < 2026.2.14 - Command Hijacking via Unsafe PATH Handling

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.14 contain a command hijacking vulnerability that allows attackers to execute unintended binaries by manipulating PATH environment variables through node-host execution or project-local bootstrapping. Attackers with authenticated access to node-host execution surfaces or those running OpenClaw in attacker-controlled directories can place malicious executables in PATH to override allowlisted safe-bin commands and achieve arbitrary command execution.

CVSS 7.7 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.14: Affected (custom)

    Update to 2026.2.14

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.14

    Update to 2026.2.14

Original sources

Check your server →