p PatchFirst

CVE-2026-31843

CVE-2026-31843 · goodoneuz/pay-uz Unauthenticated PHP File Overwrite via /payment/api/editable/update Leading to Remote Code Execution

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The goodoneuz/pay-uz Laravel package (<= 2.2.24) contains a critical vulnerability in the /payment/api/editable/update endpoint that allows unauthenticated attackers to overwrite existing PHP payment hook files. The endpoint is exposed via Route::any without authentication middleware, enabling remote access without credentials.

CVSS 10.0 · Critical · EPSS 1.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • pay-uz

    Versions
    • <= 2.2.24: Affected

    No fix published

  • goodoneuz/pay-uz Packagist

    Versions
    • 1.0
    • 1.1
    • 1.3
    • 1.4
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1
    • 2.1.1
    • 2.2
    • 2.2.1
    • 2.2.10
    • 2.2.11
    • 2.2.12
    • 2.2.13
    • 2.2.14
    • 2.2.15
    • 2.2.16
    • 2.2.17
    • 2.2.18
    • 2.2.19
    • 2.2.2
    • 2.2.20
    • 2.2.21
    • 2.2.22
    • 2.2.23
    • 2.2.24
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.2.9
    Affected ranges
    • ECOSYSTEM: < 3.0.0

    Update to 3.0.0

Original sources

Check your server →