p PatchFirst

CVE-2026-31992

CVE-2026-31992 · OpenClaw < 2026.2.23 - Allowlist Exec-Guard Bypass via env -S

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.23 contain an allowlist bypass vulnerability in system.run guardrails that allows authenticated operators to execute unintended commands. When /usr/bin/env is allowlisted, attackers can use env -S to bypass policy analysis and execute shell wrapper payloads at runtime.

CVSS 7.1 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.23: Affected (semver)

    Update to 2026.2.23

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.23

    Update to 2026.2.23

Original sources

Check your server →