p PatchFirst

CVE-2026-32033

CVE-2026-32033 · OpenClaw < 2026.2.24 - Path Traversal via @-prefixed Absolute Paths in Workspace Boundary Validation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.24 contain a path traversal vulnerability where @-prefixed absolute paths bypass workspace-only file-system boundary validation due to canonicalization mismatch. Attackers can exploit this by crafting @-prefixed paths like @/etc/passwd to read files outside the intended workspace boundary when tools.fs.workspaceOnly is enabled.

CVSS 6.0 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.24: Affected (semver)
    • 2026.2.24: Not affected (semver)

    Update to 2026.2.24

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.24

    Update to 2026.2.24

Original sources

Check your server →