p PatchFirst

CVE-2026-32042

CVE-2026-32042 · OpenClaw < 2026.2.25 - Privilege Escalation via Unpaired Device Identity in Shared Gateway Authentication

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions 2026.2.22 prior to 2026.2.25 contain a privilege escalation vulnerability allowing unpaired device identities to bypass operator pairing requirements and self-assign elevated operator scopes including operator.admin. Attackers with valid shared gateway authentication can present a self-signed unpaired device identity to request and obtain higher operator scopes before pairing approval is granted.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 2026.2.22, < 2026.2.25: Affected (semver)
    • 2026.2.25: Not affected (semver)

    Update to 2026.2.25

  • openclaw npm

    Affected ranges
    • SEMVER: ≥ 2026.2.22, < 2026.2.25

    Update to 2026.2.25

Original sources

Check your server →