p PatchFirst

CVE-2026-32061

CVE-2026-32061 · OpenClaw < 2026.2.17 - Arbitrary File Read via $include Directive Path Traversal

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions prior to 2026.2.17 contain a path traversal vulnerability in the $include directive resolution that allows reading arbitrary local files outside the config directory boundary. Attackers with config modification capabilities can exploit this by specifying absolute paths, traversal sequences, or symlinks to access sensitive files readable by the OpenClaw process user, including API keys and credentials.

CVSS 6.7 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.2.17: Affected (semver)
    • 2026.2.17: Not affected

    Update to 2026.2.17

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.17

    Update to 2026.2.17

Original sources

Check your server →