p PatchFirst

CVE-2026-32063

CVE-2026-32063 · OpenClaw 2026.2.19-2 < 2026.2.21 - Command Injection via Newline in systemd Unit Generation

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw version 2026.2.19-2 prior to 2026.2.21 contains a command injection vulnerability in systemd unit file generation where attacker-controlled environment values are not validated for CR/LF characters, allowing newline injection to break out of Environment= lines and inject arbitrary systemd directives. An attacker who can influence config.env.vars and trigger service install or restart can execute arbitrary commands with the privileges of the OpenClaw gateway service user.

CVSS 6.9 · Medium · EPSS 1.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 2026.2.19-2, < 2026.2.21: Affected (semver)
    • 2026.2.21: Not affected

    Update to 2026.2.21

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.2.21

    Update to 2026.2.21

Original sources

Check your server →