CVE-2026-32234
CVE-2026-32234 · Parse Server has a SQL injection via query field name when using PostgreSQL
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.10 and 8.6.36, an attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a $regex query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level. This vulnerability only affects Parse Server deployments using PostgreSQL. This vulnerability is fixed in 9.6.0-alpha.10 and 8.6.36.
CVSS 5.1 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
parse-server
- Versions
- >= 9.0.0 < 9.6.0-alpha.10: Affected
- < 8.6.36: Affected
No fix published
parse-server npm
- Affected ranges
- SEMVER: ≥ 9.0.0, < 9.6.0-alpha.10
Update to 9.6.0-alpha.10
parse-server npm
- Affected ranges
- SEMVER: < 8.6.36
Update to 8.6.36