p PatchFirst

CVE-2026-32905

CVE-2026-32905 · OpenClaw < 2026.5.4 - Unauthorized Device-Pairing Bootstrap Code Issuance via Chat Command

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.5.4 contains an authorization bypass vulnerability in the bundled device-pair plugin that allows non-owner authorized chat senders to issue device-pairing bootstrap codes without proper scope validation. Attackers with chat command access can create setup codes to enroll devices with operator/node capabilities, granting persistent credentials until manual removal.

CVSS 8.7 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.5.4: Affected (semver)
    • 2026.5.4: Not affected (semver)

    Update to 2026.5.4

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.5.4

    Update to 2026.5.4

Original sources

Check your server →