p PatchFirst

CVE-2026-32914

CVE-2026-32914 · OpenClaw < 2026.3.12 - Insufficient Access Control in /config and /debug Endpoints

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.12 contains an insufficient access control vulnerability in the /config and /debug command handlers that allows command-authorized non-owners to access owner-only surfaces. Attackers with command authorization can read or modify privileged configuration settings restricted to owners by exploiting missing owner-level permission checks.

CVSS 8.7 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.12: Affected (semver)
    • 2026.3.12: Not affected (semver)

    Update to 2026.3.12

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.12

    Update to 2026.3.12

Original sources

Check your server →