p PatchFirst

CVE-2026-32916

CVE-2026-32916 · OpenClaw 2026.3.7 < 2026.3.11 - Authorization Bypass in Plugin Subagent Routes via Synthetic Admin Scopes

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw versions 2026.3.7 before 2026.3.11 contain an authorization bypass vulnerability where plugin subagent routes execute gateway methods through a synthetic operator client with broad administrative scopes. Remote unauthenticated requests to plugin-owned routes can invoke runtime.subagent methods to perform privileged gateway actions including session deletion and agent execution.

CVSS 9.2 · Critical · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 2026.3.7, < 2026.3.11: Affected (semver)
    • 2026.3.11: Not affected (semver)

    Update to 2026.3.11

  • openclaw npm

    Affected ranges
    • SEMVER: ≥ 2026.3.7, < 2026.3.11

    Update to 2026.3.11

Original sources

Check your server →