p PatchFirst

CVE-2026-32920

CVE-2026-32920 · OpenClaw < 2026.3.12 - Arbitrary Code Execution via Auto-Discovery of Workspace Plugins

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenClaw before 2026.3.12 automatically discovers and loads plugins from .OpenClaw/extensions/ without explicit trust verification, allowing arbitrary code execution. Attackers can execute malicious code by including crafted workspace plugins in cloned repositories that execute when users run OpenClaw from the directory.

CVSS 8.6 · High · EPSS 0.3% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • openclaw

    Versions
    • ≥ 0, < 2026.3.12: Affected (semver)
    • 2026.3.12: Not affected (semver)

    Update to 2026.3.12

  • openclaw npm

    Affected ranges
    • SEMVER: < 2026.3.12

    Update to 2026.3.12

Original sources

Check your server →