CVE-2026-33210
CVE-2026-33210 · Ruby JSON has a format string injection vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Ruby JSON is a JSON implementation for Ruby. From version 2.14.0 to before versions 2.15.2.1, 2.17.1.2, and 2.19.2, a format string injection vulnerability can lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents. This issue has been patched in versions 2.15.2.1, 2.17.1.2, and 2.19.2.
CVSS 8.3 · High · EPSS 0.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
json
- Versions
- >= 2.14.0, < 2.15.2.1: Affected
- >= 2.16.0, < 2.17.1.2: Affected
- >= 2.18.0, < 2.19.2: Affected
No fix published
ruby-json Debian:14
- Versions
- 2.15.2+dfsg-1
- 2.18.1+dfsg-1
- 2.19.1+dfsg-1
- 2.9.1+dfsg-1
- Affected ranges
- ECOSYSTEM: < 2.19.2+dfsg-1
Update to 2.19.2+dfsg-1
ruby-json Ubuntu:14.04:LTS
- Versions
- 1.8.0-1
- 1.8.0-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:16.04:LTS
- Versions
- 1.8.3-1build1
- 1.8.3-1build2
- 1.8.3-1build4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:18.04:LTS
- Versions
- 2.1.0+dfsg-1
- 2.1.0+dfsg-1ubuntu2
- 2.1.0+dfsg-1ubuntu3
- 2.1.0+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:20.04:LTS
- Versions
- 2.1.0+dfsg-2
- 2.3.0+dfsg-1
- 2.3.0+dfsg-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:22.04:LTS
- Versions
- 2.3.0+dfsg-1build1
- 2.5.1+dfsg-2
- 2.5.1+dfsg-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:24.04:LTS
- Versions
- 2.6.3+dfsg-1build2
- 2.6.3+dfsg-1build3
- 2.6.3+dfsg-1build4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:25.10
- Versions
- 2.9.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:26.10
- Versions
- 2.18.1+dfsg-1
- 2.21.1+dfsg-1
- 2.21.2+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby-json Ubuntu:26.04:LTS
- Versions
- 2.9.1+dfsg-1
- 2.15.2+dfsg-1
- 2.18.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/ruby/json/security/advisories/GHSA-3m6g-2423-7cp3
- https://access.redhat.com/security/cve/CVE-2026-33210
- https://bugzilla.redhat.com/show_bug.cgi?id=2449871
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33210.json
- https://access.redhat.com/errata/RHSA-2026:20606
- https://access.redhat.com/errata/RHSA-2026:20596
- https://access.redhat.com/errata/RHSA-2026:57565
- https://nvd.nist.gov/vuln/detail/CVE-2026-33210