CVE-2026-33278
CVE-2026-33278 · Possible arbitrary code execution during DNSSEC validation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
NLnet Labs Unbound 1.19.1 up to and including version 1.25.0 has a vulnerability in the DNSSEC validator that enables denial of service and possible remote code execution as a result of deep copying a data structure and erroneously overwriting a destination pointer. An adversary can exploit the vulnerability by controlling a malicious signed zone and querying a vulnerable Unbound. When DS sub-queries need to suspend validation due to NSEC3 computational budget exhaustion (introduced in Unbound 1.19.1), Unbound deep-copies response messages to preserve them across memory region teardown. A struct-assignment bug overwrites the destination's pointer with the source's pointer. After the sub-query region is freed, the resumed validator dereferences this dangling pointer, triggering a crash or potentially enabling arbitrary code execution. Unbound 1.25.1 contains a patch with a fix to preserve the correct pointer when deep copying the data structure.
CVSS 9.1 · Critical · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
unbound
- Versions
- ≥ 1.19.1, < 1.25.1: Affected (semver)
Update to 1.25.1
unbound Debian:12
- Versions
- 1.17.1-2
- 1.17.1-2+deb12u1
- 1.17.1-2+deb12u2
- 1.17.1-2+deb12u3
- 1.17.1-2+deb12u4
- 1.17.1-2+loong64
- 1.18.0-1
- 1.18.0-2
- 1.19.1-1
- 1.19.2-1
- 1.20.0-1
- 1.21.1-1
- 1.22.0-1
- 1.22.0-2
- 1.23.1-1
- 1.24.0-1
- 1.24.0-2
- 1.24.1-1
- 1.24.1-2
- 1.24.2-1
- 1.25.0-1
- 1.25.1-1
- 1.25.2-1
- 1.26.0-1
- 1.26.0-2
- 1.26.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
unbound Debian:13
- Versions
- 1.22.0-2
- 1.22.0-2+deb13u1
- 1.22.0-2+deb13u2
- Affected ranges
- ECOSYSTEM: < 1.22.0-2+deb13u3
Update to 1.22.0-2+deb13u3
unbound Debian:14
- Versions
- 1.22.0-2
- 1.23.1-1
- 1.24.0-1
- 1.24.0-2
- 1.24.1-1
- 1.24.1-2
- 1.24.2-1
- 1.25.0-1
- Affected ranges
- ECOSYSTEM: < 1.25.1-1
Update to 1.25.1-1
unbound Ubuntu:24.04:LTS
- Versions
- 1.17.1-2
- 1.18.0-2ubuntu1
- 1.18.0-2ubuntu2
- 1.19.1-1ubuntu1
- 1.19.2-1ubuntu1
- 1.19.2-1ubuntu3
- 1.19.2-1ubuntu3.1
- 1.19.2-1ubuntu3.2
- 1.19.2-1ubuntu3.3
- 1.19.2-1ubuntu3.4
- 1.19.2-1ubuntu3.5
- 1.19.2-1ubuntu3.6
- 1.19.2-1ubuntu3.7
- Affected ranges
- ECOSYSTEM: < 1.19.2-1ubuntu3.8
Update to 1.19.2-1ubuntu3.8
unbound Ubuntu:25.10
- Versions
- 1.22.0-1ubuntu1
- 1.22.0-2ubuntu1
- 1.22.0-2ubuntu2
- 1.22.0-2ubuntu2.1
- 1.22.0-2ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 1.22.0-2ubuntu2.3
Update to 1.22.0-2ubuntu2.3
unbound Ubuntu:26.04:LTS
- Versions
- 1.22.0-2ubuntu2
- 1.22.0-2ubuntu4
- 1.24.2-1ubuntu1
- 1.24.2-1ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.24.2-1ubuntu2.1
Update to 1.24.2-1ubuntu2.1
Original sources
- https://www.nlnetlabs.nl/downloads/unbound/CVE-2026-33278.txt
- https://access.redhat.com/security/cve/CVE-2026-33278
- https://bugzilla.redhat.com/show_bug.cgi?id=2479808
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33278.json
- https://access.redhat.com/errata/RHSA-2026:23231
- https://access.redhat.com/errata/RHSA-2026:24369
- https://access.redhat.com/errata/RHSA-2026:19752
- https://nvd.nist.gov/vuln/detail/CVE-2026-33278