CVE-2026-33311
CVE-2026-33311 · @dicebear/core and @dicebear/initials Vulnerable to SVG Injection via Unsanitized Options
This page contains facts from public vulnerability sources. Check the original advisory before updating.
DiceBear is an avatar library for designers and developers. Starting in version 5.0.0 and prior to versions 5.4.4, 6.1.4, 7.1.4, 8.0.3, and 9.4.1, SVG attribute values derived from user-supplied options (`backgroundColor`, `fontFamily`, `textColor`) were not XML-escaped before interpolation into SVG output. This could allow Cross-Site Scripting (XSS) when applications pass untrusted input to `createAvatar()` and serve the resulting SVG inline or with `Content-Type: image/svg+xml`. Starting in versions 5.4.4, 6.1.4, 7.1.4, 8.0.3, and 9.4.1, all affected SVG attribute values are properly escaped using XML entity encoding. Users should upgrade to the listed patched versions. Some mitigating factors limit vulnerability. Applications that validate input against the library's JSON Schema before passing it to `createAvatar()` are not affected. The DiceBear CLI validates input via AJV and was not vulnerable. Exploitation requires that an application passes untrusted, unvalidated external input directly as option values.
CVSS 4.7 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
dicebear
- Versions
- >= 5.0.0, < 5.4.4: Affected
- >= 6.0.0, < 6.1.4: Affected
- >= 7.0.0, < 7.1.4: Affected
- >= 8.0.0, < 8.0.3: Affected
- >= 9.0.0, < 9.4.1: Affected
No fix published
@dicebear/core npm
- Affected ranges
- SEMVER: ≥ 5.0.0, < 5.4.4
Update to 5.4.4
@dicebear/core npm
- Affected ranges
- SEMVER: ≥ 6.0.0, < 6.1.4
Update to 6.1.4
@dicebear/core npm
- Affected ranges
- SEMVER: ≥ 7.0.0, < 7.1.4
Update to 7.1.4
@dicebear/core npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.0.3
Update to 8.0.3
@dicebear/core npm
- Affected ranges
- SEMVER: ≥ 9.0.0, < 9.4.1
Update to 9.4.1
@dicebear/initials npm
- Affected ranges
- SEMVER: ≥ 5.0.0, < 5.4.4
Update to 5.4.4
@dicebear/initials npm
- Affected ranges
- SEMVER: ≥ 6.0.0, < 6.1.4
Update to 6.1.4
@dicebear/initials npm
- Affected ranges
- SEMVER: ≥ 7.0.0, < 7.1.4
Update to 7.1.4
@dicebear/initials npm
- Affected ranges
- SEMVER: ≥ 8.0.0, < 8.0.3
Update to 8.0.3
@dicebear/initials npm
- Affected ranges
- SEMVER: ≥ 9.0.0, < 9.4.1
Update to 9.4.1