CVE-2026-33532
CVE-2026-33532 · yaml is vulnerable to Stack Overflow via deeply nested YAML collections
This page contains facts from public vulnerability sources. Check the original advisory before updating.
`yaml` is a YAML parser and serialiser for JavaScript. Parsing a YAML document with a version of `yaml` on the 1.x branch prior to 1.10.3 or on the 2.x branch prior to 2.8.3 may throw a RangeError due to a stack overflow. The node resolution/composition phase uses recursive function calls without a depth bound. An attacker who can supply YAML for parsing can trigger a `RangeError: Maximum call stack size exceeded` with a small payload (~2–10 KB). The `RangeError` is not a `YAMLParseError`, so applications that only catch YAML-specific errors will encounter an unexpected exception type. Depending on the host application's exception handling, this can fail requests or terminate the Node.js process. Flow sequences allow deep nesting with minimal bytes (2 bytes per level: one `[` and one `]`). On the default Node.js stack, approximately 1,000–5,000 levels of nesting (2–10 KB input) exhaust the call stack. The exact threshold is environment-dependent (Node.js version, stack size, call stack depth at invocation). Note: the library's `Parser` (CST phase) uses a stack-based iterative approach and is not affected. Only the compose/resolve phase uses actual call-stack recursion. All three public parsing APIs are affected: `YAML.parse()`, `YAML.parseDocument()`, and `YAML.parseAllDocuments()`. Versions 1.10.3 and 2.8.3 contain a patch.
CVSS 4.3 · Medium · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
yaml
- Versions
- >= 2.0.0, < 2.8.3: Affected
- >= 1.0.0, < 1.10.3: Affected
No fix published
node-yaml Debian:12
- Versions
- 2.1.3-2
- 2.3.1-1
- 2.3.1-2
- 2.3.4+~cs0.4.0-1
- 2.3.4-1
- 2.8.2+~cs0.4.0-1
- 2.8.3+~cs0.4.0-1
- 2.8.3+~cs0.4.0-2
- 2.8.3+~cs0.4.0-3
- 2.9.0+~cs0.4.0-1
- 2.9.0+~cs0.4.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-yaml Debian:13
- Versions
- 2.3.4+~cs0.4.0-1
- 2.8.2+~cs0.4.0-1
- 2.8.3+~cs0.4.0-1
- 2.8.3+~cs0.4.0-2
- 2.8.3+~cs0.4.0-3
- 2.9.0+~cs0.4.0-1
- 2.9.0+~cs0.4.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-yaml Debian:14
- Versions
- 2.3.4+~cs0.4.0-1
- 2.8.2+~cs0.4.0-1
- Affected ranges
- ECOSYSTEM: < 2.8.3+~cs0.4.0-1
Update to 2.8.3+~cs0.4.0-1
yaml npm
- Affected ranges
- SEMVER: ≥ 2.0.0, < 2.8.3
Update to 2.8.3
yaml npm
- Affected ranges
- SEMVER: ≥ 1.0.0, < 1.10.3
Update to 1.10.3
node-yaml Ubuntu:22.04:LTS
- Versions
- 1.10.0-4
- 1.10.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-yaml Ubuntu:24.04:LTS
- Versions
- 2.3.1-2
- 2.3.4-1
- 2.3.4-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-yaml Ubuntu:25.10
- Versions
- 2.3.4+~cs0.4.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-yaml Ubuntu:26.04:LTS
- Versions
- 2.3.4+~cs0.4.0-1
- 2.8.2+~cs0.4.0-1build1
- 2.8.3+~cs0.4.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published