CVE-2026-33658
CVE-2026-33658 · Rails Active Storage has a possible DoS vulnerability in proxy mode via multi-range requests
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Active Storage allows users to attach cloud and local files in Rails applications. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 Active Storage's proxy controller does not limit the number of byte ranges in an HTTP Range header. A request with thousands of small ranges causes disproportionate CPU usage compared to a normal request for the same file, possibly resulting in a DoS vulnerability. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.
CVSS 2.3 · Low · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
activestorage
- Versions
- >= 8.1.0, < 8.1.2.1: Affected
- >= 8.0.0, < 8.0.4.1: Affected
- < 7.2.3.1: Affected
No fix published
rails Debian:13
- Versions
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-1
- 2:7.2.2.2+dfsg-2~deb13u1
- Affected ranges
- ECOSYSTEM: < 2:7.2.2.2+dfsg-2~deb13u2
Update to 2:7.2.2.2+dfsg-2~deb13u2
rails Debian:14
- Versions
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-1
- 2:7.2.2.2+dfsg-2
- 2:7.2.2.2+dfsg-2~deb13u1
- 2:7.2.2.2+dfsg-2~deb13u2
- 2:7.2.3+dfsg-1
- 2:7.2.3+dfsg-2
- 2:7.2.3+dfsg-3
- Affected ranges
- ECOSYSTEM: < 2:7.2.3.1+dfsg-1
Update to 2:7.2.3.1+dfsg-1
rails Ubuntu:Pro:16.04:LTS
- Versions
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:18.04:LTS
- Versions
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:20.04:LTS
- Versions
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:22.04:LTS
- Versions
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:24.04:LTS
- Versions
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:25.10
- Versions
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:26.10
- Versions
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:26.04:LTS
- Versions
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/rails/rails/security/advisories/GHSA-p9fm-f462-ggrg
- https://github.com/rails/rails/releases/tag/v7.2.3.1
- https://github.com/rails/rails/releases/tag/v8.0.4.1
- https://github.com/rails/rails/releases/tag/v8.1.2.1
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activestorage/CVE-2026-33658.yml
- https://nvd.nist.gov/vuln/detail/CVE-2026-33658